HomePortalFAQSearchMemberlistUsergroupsRegisterLog in
The domain www.kitopen.com will expire on 2018-08-17. Update your bookmarks to point at http://kito.forumotion.com/
You can use google search to find threads and posts here now. Example

Share
 

 Item problem...maybe

Go down 
AuthorMessage
Lunarwolf22

Lunarwolf22

Female Posts : 74
Join date : 2015-01-10
Age : 19

item - Item problem...maybe Empty
PostSubject: Item problem...maybe   item - Item problem...maybe I_icon_minitimeSun Jul 24, 2016 3:54 pm

I tried to make a halo from particles using a shard, but when I tested I got this error:

item - Item problem...maybe 2rwom8n

(if you cant see the pic, look here:http://tinypic.com/view.php?pic=2rwom8n&s=9#.V5Tj_j_r2po and btw, in this picture I tried to spawn a sword which had a shard with it, but it's the same error with the 'halo situation')
If you cant see it says: OGRE EXCEPTION(5:ItemIdentityException)Entity is not animated in Entity.......
Back to top Go down
lazyzim

™
lazyzim

Server : Dragon's Den
Male Posts : 765
Join date : 2011-11-27

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeMon Jul 25, 2016 11:30 am

Did you attach a bone to it?
Can't read what it says on the screenshot.
Back to top Go down
Lunarwolf22

Lunarwolf22

Female Posts : 74
Join date : 2015-01-10
Age : 19

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeMon Jul 25, 2016 5:06 pm

lazyzim wrote:
Did you attach a bone to it?
Can't read what it says on the screenshot.

attach a bone to it?? idk x3
it says: OGRE EXCEPTION(5:ItemIdentityException)Entity is not animated in Entity::getAnimationState at D:\kito-dev\ogre_src_v1-7-4\OgreMain\src\OgreEntity.cpp(line 667)
Back to top Go down
venw0lf

venw0lf

Game username : Venwolf
Server : Last Moon (Global Mod)
Female Posts : 107
Join date : 2015-05-14
Age : 17
Location : off the grid

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeTue Jul 26, 2016 3:05 am

That means the item isn't rigged correctly. AKA it needs animations and a proper bone.
Back to top Go down
Lunarwolf22

Lunarwolf22

Female Posts : 74
Join date : 2015-01-10
Age : 19

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeWed Jul 27, 2016 8:45 am

Yeah, but it works with other items for example antlers, ties e.t.c How?
Back to top Go down
venw0lf

venw0lf

Game username : Venwolf
Server : Last Moon (Global Mod)
Female Posts : 107
Join date : 2015-05-14
Age : 17
Location : off the grid

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeWed Jul 27, 2016 2:38 pm

What do you mean it works with other items?

Antlers and ties that work are properly rigged and animated which is why they work.
The sword that has a particle on it doesn't work because of the sword itself.
The mesh itself must be rigged and have item animations to work ingame.
Back to top Go down
Lunarwolf22

Lunarwolf22

Female Posts : 74
Join date : 2015-01-10
Age : 19

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeFri Jul 29, 2016 9:04 pm

By 'it' I mean that the shard works with antlers, ties e.t.c And thanks for the info c: too bad I dont know modeling....yet xD
Back to top Go down
Hyper
Admin
Hyper

Game username : Hyper
Server : Azoptaos
Male Posts : 564
Join date : 2014-02-09
Age : 21

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeSat Jul 30, 2016 12:26 am

what mesh are you attaching to the shard?

________________________________
i can code you things
Back to top Go down
http://azoptaos.boards.net/
Lunarwolf22

Lunarwolf22

Female Posts : 74
Join date : 2015-01-10
Age : 19

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeSat Jul 30, 2016 9:03 am

The sword that the image shows that I tried to spawn was given by Skyia in order to put the shard, make a "magic sword" and then give it to her as a "new" item(I asked her to give me only the mesh btw). And when I combined the shard with the sword and tested I got that error. The mesh was a sword (I cant remember the mesh name)
Back to top Go down
Hyper
Admin
Hyper

Game username : Hyper
Server : Azoptaos
Male Posts : 564
Join date : 2014-02-09
Age : 21

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeSat Jul 30, 2016 9:09 am

she gave you only a mesh? thats the problem - you need a skeleton for it

________________________________
i can code you things
Back to top Go down
http://azoptaos.boards.net/
Lunarwolf22

Lunarwolf22

Female Posts : 74
Join date : 2015-01-10
Age : 19

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeSun Jul 31, 2016 9:18 am

Oh I understand now. Thanks Hyper c: okay I think this problem is solved
Back to top Go down
Hyper
Admin
Hyper

Game username : Hyper
Server : Azoptaos
Male Posts : 564
Join date : 2014-02-09
Age : 21

item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitimeSun Jul 31, 2016 9:45 am

no problem, glad you could figure it out!

________________________________
i can code you things
Back to top Go down
http://azoptaos.boards.net/
Sponsored content




item - Item problem...maybe Empty
PostSubject: Re: Item problem...maybe   item - Item problem...maybe I_icon_minitime

Back to top Go down
 
Item problem...maybe
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Keeping I.T. Open :: SUPPORT :: Support :: Solved Support Issues-
Jump to: