HomePortalFAQSearchMemberlistUsergroupsRegisterLog in
The domain www.kitopen.com will expire on 2018-08-17. Update your bookmarks to point at http://kito.forumotion.com/
Meet the new KITO admins & hear their plans here.
You can use google search to find threads and posts here now. Example

Share | 
 

 New Buttons problem

Go down 
AuthorMessage
DarkHeta

avatar

Game username : DarkHeta
Server : Eternal Time
Female Posts : 70
Join date : 2016-01-18
Age : 18
Location : Russia

PostSubject: New Buttons problem   Wed Apr 11, 2018 8:23 pm

I create a new gui box for spells.

Add in define numbers:


Create actions for buttons:


But in game work only close button!



Back to top Go down
https://vk.com/eternaltimenewserver
Hyper
Admin
avatar

Game username : Hyper
Server : Azoptaos
Male Posts : 553
Join date : 2014-02-09
Age : 20

PostSubject: Re: New Buttons problem   Thu Apr 12, 2018 3:01 am

did you initialize the button to the correct gui element?

________________________________
i can code you things
Back to top Go down
http://azoptaos.boards.net/
DarkHeta

avatar

Game username : DarkHeta
Server : Eternal Time
Female Posts : 70
Join date : 2016-01-18
Age : 18
Location : Russia

PostSubject: Re: New Buttons problem   Thu Apr 12, 2018 4:53 am

Hyper wrote:
did you initialize the button to the correct gui element?
Yes. Buttons is mButtons, box is mBox, mover is mMover

And I add Button_spells (and all buttons) in button list (there was buttons from stash, items and so on)
Add Spell_Box in Box list
Add Spell_Mover in mover list
Back to top Go down
https://vk.com/eternaltimenewserver
Hyper
Admin
avatar

Game username : Hyper
Server : Azoptaos
Male Posts : 553
Join date : 2014-02-09
Age : 20

PostSubject: Re: New Buttons problem   Thu Apr 12, 2018 5:11 am

i know you defined them, but did you initialize them? in MagixGUI you'll see a whole bunch of intializations in the class's initialize function. you need to set all of the buttons to correspond to the gui overlay element you created like this:

Quote :
mButton[BUTTON_SPELL1] = OverlayManager::getSingleton().getOverlayElement("GUI/ElementNameHere");

________________________________
i can code you things
Back to top Go down
http://azoptaos.boards.net/
DarkHeta

avatar

Game username : DarkHeta
Server : Eternal Time
Female Posts : 70
Join date : 2016-01-18
Age : 18
Location : Russia

PostSubject: Re: New Buttons problem   Thu Apr 12, 2018 2:34 pm

Hyper wrote:
i know you defined them, but did you initialize them? in MagixGUI you'll see a whole bunch of intializations in the class's initialize function. you need to set all of the buttons to correspond to the gui overlay element you created like this:

Quote :
mButton[BUTTON_SPELL1] = OverlayManager::getSingleton().getOverlayElement("GUI/ElementNameHere");

Back to top Go down
https://vk.com/eternaltimenewserver
Sponsored content




PostSubject: Re: New Buttons problem   

Back to top Go down
 
New Buttons problem
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Keeping I.T. Open :: SUPPORT :: Support-
Jump to: